Downgrading PHP 5.4 to 5.3 on Ubuntu 12.10 (Quantal)

I recently upgraded one of my staging servers to Ubuntu 12.10 (aka Quantal). That’s great, except my production servers are still on Ubuntu 11.04. The idea behind having a staging environment is to match production as closely as possible. So, my choices are (a) upgrade my production systems, which is a good idea but risky, or (b) downgrade PHP on my staging servers. For various reasons relating to time and cost, I decided it would be best to temporarily downgrade PHP on my staging servers.
Continue reading…